
Calibrating E/S Series Devices 
with Calibration Executive

This document contains instructions for loading and running the National 
Instruments Calibration Executive procedure for E/S Series devices with 
Traditional NI-DAQ. 
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Equipment and Other Test Requirements
This section describes the equipment, test conditions, documentation, 
and software needed to calibrate E or S Series devices.

Test Equipment
To calibrate an E/S Series device, you need a calibrator, a digital 
multimeter (DMM), and a counter. NI recommends using the following test 
equipment:

• Calibrator—Fluke 5700A

• DMM—Agilent (HP) 34401A

• Counter—Agilent (HP) 53131A

• Low thermal copper EMF plug-in cables—Fluke 5440A-7002. 
Do not use standard banana cables.

Note The Calibration Executive procedure runs in automated mode if you use 
IVI-supported calibration standards. For more information about automated versus 
manual modes, refer to the Calibration Executive Software User Manual.

If you do not have the recommended test equipment, use the following 
accuracy requirements to select substitute calibration standards.

• A calibrator that is 4 to 10 times more accurate than the 
analog-to-digital converter (ADC) on the E/S Series device. When 
calibrating a 12-bit device, the calibrator should be at least 50 ppm 
(0.005%) accurate. When calibrating a 16-bit device, the calibrator 
should be at least 10 ppm (0.001%) accurate.

• A multiranging 5 1/2 digit DMM with an accuracy of 15 ppm. 

Connectors
The automated Calibration Executive procedure for E/S Series devices is 
designed to work with the following connection hardware:

• An E Series calibration fixture. For S Series devices (for example, 
NI 61XX), use revision B or later of the calibration fixture.

• A connector cable, as described in Table 1.
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Test Conditions
Follow these guidelines to optimize the connections and the environment 
during calibration:

• Keep connections to the E/S Series device short. Long cables and 
wires act as antennae, picking up extra noise that can affect 
measurements.

• Use shielded copper wire for all cable connections to the device. 
Use twisted-pair wire to eliminate noise and thermal offsets.

• Maintain a temperature between 18 °C and 28 °C.

• Keep the relative humidity below 80%.

• Warm up the E/S Series device for at least 15 minutes to ensure that its 
measurement circuitry is at a stable operating temperature.

Calibration Temperature Considerations
Temperature change affects the measurement characteristics of a device. 
To account for these changes, the tested specifications include the effects 
of temperature drift. For the E/S Series devices, valid temperature drift is 
±10 °C from the last external calibration temperature.

Table 1.  Recommended Cables 

Device Cable

E/S Series devices with a 68-pin SCSI II 
connector

SH68-68-EP

E/S Series devices with a 68-pin VHDCI 
connector (for example, DAQCard-6036E)

SHC68-68-EP

E/S Series devices with a 100-pin connector 
(for example, PCI/PXI-6025E, 
PCI/PXI-6031E, PCI/PXI-6033E, 
PCI/PXI-6071E)

SH1006868. Connect the 68-pin cable labeled 
MIO-16 to the accessory. The 68-pin cable labeled 
Extended I/O remains unconnected.
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Documentation
In addition to this calibration procedure, you may want to refer to the 
following documents:

• Calibration Executive Software User Manual

• E Series Calibration Fixture Installation Guide

• Hardware documentation for the E/S Series device you are calibrating

You can download the latest versions of these documents from 
ni.com/manuals.

You also may need to refer to the Measurement & Automation Explorer 
Help for Traditional NI-DAQ. You can access this help file by launching 
Measurement & Automation Explorer (MAX) and selecting Help»Help 
Topics»Traditional NI-DAQ from the main menu.

Software
For information about installing and uninstalling Calibration Executive 
procedures, refer to the Calibration Executive Software User Manual.

The Calibration Executive setup program installs Calibration Executive 
and the associated files listed in Table 2.

Table 2.  Calibration Executive Directories and Supporting Files

Directory Name Contents

Program Files\National Instruments\

Calibration Executive\Procedures\

E Series S Series

Directory structure that contains the calibration 
procedure and this document

Program Files\National Instruments\
Calibration Executive\Procedures\
E Series S Series\Limits

Microsoft Access databases that store the 
calibration limits

Program Files\National Instruments\

Calibration Executive\Procedures\

E Series S Series\Support Files

Support files such as bitmaps and DLLs
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Calibration Executive Procedures
This section explains how to set up and run the Calibration Executive 
procedure. In automated mode, the procedure takes about 30 minutes. 
In manual mode, the calibration procedure can take as long as one hour.

Setting Up the E/S Series Device for Calibration
To set up the device for calibration, complete the following steps: 

1. Install the E/S Series device in the host computer.

2. Configure the hardware with MAX. Refer to the Measurement & 
Automation Explorer Help for Traditional NI-DAQ or visit 
ni.com/support for more configuration information.

3. Connect the appropriate shielded cables between the E/S Series 
device, the calibration fixture, and the standards, as shown in 
Figures 1 and 2.

Figure 1.  Connecting the Counter, DMM, and Calibrator

HI LO Guard

Calibrator

HILO

DMMCounter

E Series Device

Shielded Cable
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Note Fluke 5500A and 5520A calibrators do not have guard connectors. You must 
connect the LO cable with the guard cable, and then connect the guard cable into the 
LO terminal on the calibrator, as shown in Figure 2.

Figure 2.  Connecting the Counter, DMM, and Fluke 5500A/5520A Calibrator

Loading and Running the Calibration Executive Procedure
To load and run the Calibration Executive procedure, complete the 
following steps:

1. Launch Calibration Executive.

2. Follow the Calibration Configuration Wizard to load the E/S Series 
calibration procedure. For more information about loading and 
running the calibration procedure, refer to the Calibration Executive 
Software User Manual.

3. When the procedure is loaded, click Run Procedure.

4. When the Calibration Executive procedure asks you whether to 
calculate measurement uncertainty, select Yes or No. If you select Yes, 
you are prompted to select the appropriate uncertainty files based on 
the standards you are using and the date the standards were last 
calibrated.

HI LO

Calibrator

HILO

DMMCounter

E Series Device

Shielded Cable

Guard
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5. When the Calibration Executive procedure prompts you for 
information about the installed hardware, enter the following 
information:

• Device Number—The Traditional NI-DAQ device number 
assigned to the E/S Series device by MAX when you configured 
the hardware.

• Supported Products—The appropriate device from the menu 
that lists the devices supported by the calibration procedure.

Viewing the Calibration Report
When the calibration procedure is finished, complete the following steps to 
view the calibration report.

1. Select View»Reports.

2. Click View. 

Modifying the Font Size in a Calibration Report
If you have selected the HTML format and the text size in the calibration 
report is too large, you can decrease the size as follows:

• In Internet Explorer, modify the text size by selecting View»Text Size 
and then selecting the appropriate size from the menu.

• In Netscape, modify the text size by selecting View»Decrease Font.

Note If the E/S Series device fails after calibration, refer to the Troubleshooting 
Guidelines section. If the device still fails after you complete the troubleshooting 
procedures, return it to NI for repair or replacement.

Measurement Uncertainty Considerations 
and Calculations

For information about how Calibration Executive handles measurement 
uncertainty, refer to the Calibration Executive Software User Manual.

The components of uncertainty vary depending on which test is running. 
The E/S Series device calibration procedure runs up to three main tests, 
depending on which device you are calibrating. Each test takes different 
uncertainty components into account. 

After Calibration Executive calculates all the components of uncertainty, 
the components are converted to a 1-sigma normal distribution, and are 
then combined using the root-sum-square method. The combined standard 
uncertainty is then multiplied by an appropriate coverage factor, taking 
degrees of freedom into account, to arrive at the reported expanded 
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uncertainty of measurement, which corresponds to a coverage probability 
of approximately 95%. The following sections describe the uncertainty 
budgets for counter, analog input, and analog output uncertainties for 
E/S Series devices.

Counter Uncertainty
This section describes the components of counter uncertainty in the 
E/S Series device Calibration Executive procedure.

You must manually calculate final expanded counter uncertainty at a 95% 
confidence level based on the manufacturer’s specifications for the counter 
and your own Type A calculations. Enter this value when the procedure 
prompts you for it. A suggested final expanded uncertainty value is 
computed as follows: 

where

where 10 is the number of measurements taken.

Type B uncertainty can be calculated as shown in the following example, 
which measures a 5 MHz square wave signal (which has negligible trigger 
error) with a one second gate time. This example is for an HP53132A 
counter with a high-stability oven that was calibrated three days before.

where

Number of Samples is 200,000 (because frequency > 200 kHz)

Gate Time is 1 second

Time Base Error is Temp. Stability × (3 Days * Daily Aging Rate)

tacc is the timebase accuracy of the counter (from the hardware 
documentation)

Counter Uncertainty Type A Uncertainty( )2 Type B Uncertainty( )2+=

Type A Expanded Uncertainty 1.96 Std. Dev. of Measurements Taken
10

---------------------------------------------------------------------------------×=

Type B Uncertainty Systematic Uncertainty 1.96± RMS Resolution×

Time Base Error±
tacc

Gate Time
-------------------------± 

  1.96±

4 tres
2 2 Trigger Error2×( )+×

Gate Time Number of Samples×
----------------------------------------------------------------------------------

tjitter

Gate Time
-------------------------+

 
 
 

×

Frequency×

= =
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tjitter is the jitter specification of the counter (from the hardware 
documentation)

tres is the rms resolution of the counter (from the hardware 
documentation)

= 2.5 × 10–9 +3 × (5 × 10–10)

= 4.0 × 10–9

= [±4.0 × 10–9 ± 1.96 × (2.01 × 10–12 + 3 × 10–12)] × 5 MHz

= (±4.0 × 10–9 ±9.8 × 10–12) × 5 MHz

= ±20.05 mHz

Analog Input Uncertainty
Table 3 contains the names and descriptions of the components of analog 
input uncertainty in the E/S Series device Calibration Executive procedure.

Table 3.  Analog Input Uncertainty

Uncertainty Component Description

Calibrator uncertainty Retrieved from the calibrator uncertainty text file1

Resolution uncertainty of 
the E/S Series device

where Resolution of the E or S Series Device is the range 
of the E/S Series device divided by the number of levels in 
the ADC. The  term in the denominator results from 
assuming a rectangular distribution of probabilities of the 
measurement values.

Type A uncertainty

where 10,000 is the number of measurements taken

Leads, wiring, and calibration fixture Insignificant compared with other uncertainty components

1 For more information about the text file format, refer to the Calibration Executive Software User Manual.

Type B Uncertainty 4.0 10 9–× 1 10 11– s×
1s

------------------------±± 
  1.96

4 255 10 12– s×( )2 1.96 0×( )+×
1s 200 000,×

---------------------------------------------------------------------------------- 3 10 12– s×
1s

------------------------+ 
 

×±

5 MHz×

=

1
2
--- Resolution of E or S Series Device

3
---------------------------------------------------------------------------------- 
 =

3

Standard Deviation of Measurements Taken
10,000

----------------------------------------------------------------------------------------------------------=
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Analog Output Uncertainty
Table 4 contains the names and descriptions of the components of analog 
output uncertainty in the E/S Series device Calibration Executive 
procedure.

Note If you use the recommended test equipment and follow the test conditions 
guidelines, the vast majority of the uncertainty for the analog input tests is due to the 
resolution uncertainty of the ADC on the E/S Series device. The majority of the uncertainty 
for the analog output tests is due to the resolution uncertainty of the DAC on the E/S Series 
device. Other uncertainty components are negligible compared to these components.

Troubleshooting Guidelines
This section describes common problems you might encounter when 
calibrating an E/S Series device and explains how to correct the problem.

If the E/S Series device is not recognized by MAX, verify that you followed 
the configuration guidelines. Additional configuration information is 
available at ni.com/support. If MAX fails to recognize the E/S Series 
device after you reconfigure and refresh (<F5>), contact NI technical 
support.

Table 4.  Analog Output Uncertainty

Uncertainty Component Description

DMM uncertainty Retrieved from the DMM uncertainty text file.1

Resolution uncertainty of
the E/S Series device

where Resolution of the E or S Series Device is the range of 
the E/S Series device divided by the number of levels in the 
digital-to-analog-converter (DAC). The  term in the 
denominator results from assuming a rectangular 
distribution of probabilities of the measurement values.

Type A uncertainty

where 10 is the number of measurements taken and 1.06 
accounts for the t-distribution. 

Leads, wiring, and calibration fixture Insignificant compared with other uncertainty components.

1 For more information on the text file format, refer to the Calibration Executive Software User Manual.

1
2
--- Resolution of E or S Series Device

3
---------------------------------------------------------------------------------- 
 =

3

Standard Deviation of Measurements Taken
10

---------------------------------------------------------------------------------------------------------- 1.06×=
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If the E/S Series device fails after calibration, complete the following steps:

1. Check the connections and run the Calibration Executive procedure 
again.

2. Verify that you do not have an SCXI chassis configured in MAX. 
Remove the configuration if it is present and run the Calibration 
Executive procedure again.

3. If the calibration still fails after you complete steps 1 and 2, try 
inputting or outputting the failed test points using the test panel in 
MAX. For example, if the analog input (AI) failed at 0.98 V, input that 
value from the calibrator, as follows: 

a. Launch the Traditional NI-DAQ test panel in MAX.

b. Click the Analog Input tab.

c. Set the High Limit to 1.00 V and set the Low Limit to –1.00 V 
for bipolar readings. 

d. Check the Average Reading indicator. 

If the Average Reading still fails after you complete steps 1–3, contact NI 
for repair or replacement. If the Average Reading passes, you can change 
the calibration report to indicate the passing value. 

Note If you have Microsoft Access 2000 or later, you can also modify the database 
containing the test results. The default installation directory of this database is Program 
Files\National Instruments\Calibration Executive\Databases\
Calibration Reports.mdb. For more information on the database format, refer to the 
Calibration Executive Software User Manual.

Traditional NI-DAQ Errors and Other Errors
This section describes some of the common errors that can occur when 
calibrating an E/S Series device.

Error Code –10005
Error code –10005 indicates that the device number you selected is not 
configured or recognized in MAX. Configure the device in MAX and 
restart Calibration Executive.

Error Code –10842
Error code –10842 has different causes depending on whether the device 
you are calibrating is an AT-bus E Series device or another type of 
E/S Series device.
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♦ Error code –10842 with AT-bus E Series devices

Error code –10842 during internal calibration of an AT-bus E Series device 
may indicate that an interrupt request (IRQ) level was not assigned by the 
operating system. Test the resources in MAX to confirm this error. 
To correct the error, go to ni.com/support/install and complete the 
following steps of the Hardware Installation/Configuration 
Troubleshooter.

1. For Hardware, enter data aquisition (DAQ).

2. For Bus Type, enter AT/ISA (Plug and Play).

3. Enter your operating system and click Submit.

4. Look for information about resource conflicts or resource issues.

If the information in the Hardware Installation/Configuration 
Troubleshooter does not correct the problem, contact NI for technical 
support. The Technical Support Resources section contains information on 
how to contact NI.

♦ Error code –10842 with all other E/S Series devices

Error code –10842 during internal calibration of other E/S Series devices 
indicates that the hardware is not responding correctly and the device needs 
repair. When you contact NI for repair, explicitly indicate that the 
E/S Series calibration function returns error –10842 during internal 
calibration.

Error Code –15
Error code –15 at the beginning of the calibration procedure indicates that 
the computer may be configured to use commas as decimal places. 
Calibration Executive only supports using periods (.) for decimal places. 
To change this configuration on the computer, complete the following 
steps:

1. Select Start»Settings»Control Panel.

2. Click Regional Options.

3. Click the Numbers tab and change the Decimal Symbol from a 
comma (,) to a period (.). Change the Digit Grouping Symbol from (.) 
to (,).

Note If you change the Regional Settings or Regional Options on the computer, remember 
to change them back to the default settings after running the Calibration Executive 
procedure.
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Other Error Codes
You can find more information on other error codes in the Status Codes 
section of the Traditional NI-DAQ Function Reference Help. To launch 
this help file, select Start»Programs»National Instruments»NI-DAQ» 
Traditional NI-DAQ Function Reference Help.

Note For a list of DAQmx error codes in LabVIEW, refer to the LabVIEW Help. To launch 
this help file, select Start»Programs»National Instruments»LabVIEW»VI, Function, 
& How-to Help. Within the help file, select Running and Debugging VIs»Error Codes 
and Messages»Ranges of LabVIEW Error Codes.

Specifications
For E/S Series device specifications, refer to one of the following 
documents:

• The manual calibration procedure for the device, which is available 
for download at ni.com/calibration

• The product data sheet, which is available for download at 
ni.com/products

• The hardware documentation for the device, which is available for 
download at ni.com/manuals

Technical Support Resources

NI Web Support
National Instruments Web support is your first stop for help in solving 
installation, configuration, and application problems and questions. Online 
problem-solving and diagnostic resources include frequently asked 
questions, knowledge bases, product-specific troubleshooting wizards, 
manuals, drivers, software updates, and more. Web support is available 
through the Technical Support section of ni.com.

A Declaration of Conformity (DoC) is our claim of compliance with the 
Council of the European Communities using the manufacturer’s 
declaration of conformity. This system affords the user protection for 
electronic compatibility (EMC) and product safety. You can obtain the DoC 
for your product by visiting ni.com/hardref.nsf. If your product 
supports calibration, you can obtain the calibration certificate for your 
product at ni.com/calibration.
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Worldwide Support
National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. You can access our branch office Web sites 
from the Worldwide Offices section of ni.com. Branch office Web sites 
provide up-to-date contact information, support phone numbers, email 
addresses, and current events. 

If you have searched the technical support resources on our Web site 
and still cannot find the answers you need, contact your local office or 
National Instruments corporate. For telephone support in the United States, 
dial 512 795 8248. For telephone support outside the United States, contact 
your local branch office: 

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, 
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 
Canada (Calgary) 403 274 9391, Canada (Ottawa) 613 233 5949, 
Canada (Québec) 450 510 3055, Canada (Toronto) 905 785 0085, 
Canada (Vancouver) 514 685 7530, China 86 21 6555 7838, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 0 9 725 725 11, France 33 0 1 48 14 24 24, 
Germany 49 0 89 741 31 30, Greece 30 2 10 42 96 427, 
India 91 80 51190000, Israel 972 0 3 6393737, Italy 39 02 413091, 
Japan 81 3 5472 2970, Korea 82 02 3451 3400, Malaysia 603 9131 0918, 
Mexico 001 800 010 0793, Netherlands 31 0 348 433 466, 
New Zealand 0800 553 322, Norway 47 0 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, 
Russia 7 095 783 68 51, Singapore 65 6226 5886, 
Slovenia 386 3 425 4200, South Africa 27 0 11 805 8197, 
Spain 34 91 640 0085, Sweden 46 0 8 587 895 00, 
Switzerland 41 56 200 51 51, Taiwan 886 2 2528 7227, 
Thailand 662 992 7519, United Kingdom 44 0 1635 523545
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